Advertisement
Not a member of Pastebin yet?
Sign Up,
it unlocks many cool features!
- [Unfinished] Step-By-Step Minimum 871w Conf for CCP 2.7
- ---
- NOTE: This assumes the current conf is factory default. See, link [9] for instructions to reset router.
- 1) Customize hostname [1],
- My device name is TooterTurtle
- router(config)#hostname TooterTurtle
- 2) Add some best practice commands [2],
- TooterTurtle(config)#no ip domain lookup
- TooterTurtle(config)#no logging console
- 3) Checking the 871w's device interface names,
- TooterTurtle#show ip interface brief
- Interface IP-Address OK? Method Status Protocol
- FastEthernet0 unassigned YES unset up up
- FastEthernet1 unassigned YES unset up down
- FastEthernet2 unassigned YES unset up down
- FastEthernet3 unassigned YES unset up down
- FastEthernet4 unassigned YES unset administratively down down
- Dot11Radio0 unassigned YES unset administratively down down
- Vlan1 unassigned YES unset up up
- 4) Configure basic configuration requirements for CCP 2.7 [3],
- The CCP Release notes list the basic configuration required to use CCP; however, in my experience this was insufficient for device discovery. Nevertheless, these are all necessary conf settings.
- TooterTurtle#conf t
- TooterTurtle(config)#ip http server
- TooterTurtle(config)#ip http authentication local
- TooterTurtle(config)#line vty 0 4 // THis is shown in the url as "0 15";
- TooterTurtle(config-line)#login local
- TooterTurtle(config-line)#transport input telnet
- TooterTurtle(config-line)#transport output telnet
- TooterTurtle(config-line)#exit
- TooterTurtle(config)#username admin privilege 15 secret xxxxxxxx
- TooterTurtle(config)#write mem
- 5) Try CCP.
- To try CCP at this stage there are a few steps to follow in CCP.
- 5.1) Run application as admin
- 5.2) Create new community. My community is named, MrWizardsWorld
- 5.3) From menu Application >> Setup New Device -> Setup Wizard.
- Settings for this 871 only work with vlan. Select device vlan and enter the network address you've chosen for your internal network here, plus the user and password from step #4.
- 5.4) My settings command preview:
- conf t
- username admin privilege 15 secret 0 *****
- interface Vlan1
- ip address 192.168.10.1 255.255.255.0
- no shutdown
- exit
- ip http server
- ip http authentication local
- ip http timeout-policy idle 60 life 86400 requests 10000
- line vty 0 4
- login local
- transport input telnet
- exit
- exit
- 5.5) Also, check the option boxes.
- YES - Backup current running configuration on the device flash
- YES - Add this device to the CCP's currently selected community
- 5.6) Discovery = Failed
- The above settings were sufficient to complete the wizard procedure; however, once finished and back at the main screen (Home >> Community View or Home >> Dashboard, depending on how you navigate the application) device discovery fails.
- 6) Troubleshooting from CCP User's Guide
- 6.1) There are several Java settings to check. see "Cisco CP Configuration Requirements" p.122
- 6.2) Go to page 129 and table 2-7 for more troubleshooting tips:
- "Connection to the device could not be established. Either the device is not reachable or the HTTP service is not enabled on the device."
- This error message is displayed in one of the following conditions:
- - The CLI ip route <x.x.x.x> <x.x.x.x> <x.x.x.x> is missing in the configuration.
- From this How-to [4] there may be a disconnect between the wizard setup of vlan1 and this requirement
- "Notice that you cannot configure IP addresses under the “interface FastEthernet0? up to “interface FastEthernet3? ports. Those ports are Layer 2 switch ports and will inherit the IP address you assign under “interface Vlan1?."
- 6.3) Add ip route line from [5]
- TooterTurtle(config)#ip route 0.0.0.0 0.0.0.0 FastEthernet4
- 6.4) Enable routing [6]
- "...ip routing command...turns on the routing process."
- TooterTurtle(config)#ip routing
- 6.5) p355 #show ip route [Note. This output does not change substantially between a successful and unsuccessful conf]
- TooterTurtle#show ip route
- Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
- D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
- N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
- E1 - OSPF external type 1, E2 - OSPF external type 2
- i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
- ia - IS-IS inter area, * - candidate default, U - per-user static route
- o - ODR, P - periodic downloaded static route
- Gateway of last resort is not set
- C 192.168.10.0/24 is directly connected, Vlan1
- 7.) Continue with another CLI How-To: "CISCO 871W configuration for Small Offices"
- As stated in my OP, this is not the configuration I want for my network. I'm only using it because the instructions do create a successful conf. What's strange is the difference between the stated requirements in #4 above and all that is included in #7 below. I believe there must be some smaller configuration, one without bridging, or dhcp, perhaps? Right now this is it. The headers listed here are from that document (mostly) and in the order presented on that site.
- 7.1) Skip "Creating Vlans",
- You shouldn't need to create vlan1 because its a necessary default for 871w, because FE0-FE3 are L2 and will not accept ip statement directly. Certainly, if your conf doesn't have Vlan1, you will need to create it. Following this step, the other important part of these instructions is the assignment of a "name" property to Vlan1 which is used throughout the How-To.
- If you're a noob like me, then attempting to set this property you may encounter the following problems. The CLI complains about using the vlan database. I found a forum post Rosetta explaining how to configure the vlan name property [7] in the preferred manner; however, changing the name of the default vlan is not supported [8]. Going forward, when comparing these instructions with the How-To site you will find where the author used the given name for their vlan config, I simply used vlan1.
- 7.2) Skip "Services, security and logging configurations required",
- This isn't necessary for CCP.
- 7.3) Skip Authentication, Authorization and Accounting",
- In a previous attempt CCP generated a connection error about managing users with aaa.
- 7.4) Do "Others configurations required"
- TooterTurtle#conf t
- TooterTurtle(config)#no ip source-route
- TooterTurtle(config)#no ip gratuitous-arps
- TooterTurtle(config)#no ip bootp server
- /** already set ip routing **/
- TooterTurtle(config)#ip cef
- TooterTurtle(config)#ip domain name Tooter
- TooterTurtle(config)#bridge irb
- TooterTurtle(config)#no cdp run
- TooterTurtle(config)#exit
- 7.5) Skip "Configuring Radio and SSID`s",
- The How-To seems to over extend this header, since several non-wifi related commands are sub-headers of this section.
- 7.6) Fast Forward "At this part, we will configure the VLAN’s",
- TooterTurtle(config)#int vlan 1
- TooterTurtle(config-if)#no ip address
- TooterTurtle(config-if)#no ip redirects
- TooterTurtle(config-if)#no ip unreachable
- TooterTurtle(config-if)#no ip proxy-arp
- TooterTurtle(config-if)#ip nat inside
- TooterTurtle(config-if)#ip virtual-reassembly
- TooterTurtle(config-if)#bridge-group 1
- TooterTurtle(config-if)#exit
- [Skip vlan 20 config.
- NOTE: Actually, what I'm skipping is the How-To's Vlan10/GUEST settings. Instead I'm implementing Vlan20/INTERNAL as Vlan1.]
- 7.7) Do "“A BVI (Bridge Group Virtual Interface) is a routed interface...",
- TooterTurtle(config)#conf t
- TooterTurtle(config-if)#ip address 192.168.10.1 255.255.255.0
- TooterTurtle(config-if)#ip nat inside
- TooterTurtle(config-if)#ip virtual-reassembly
- TooterTurtle(config-if)#exit
- [The next sub-section, "Now we define a default route. Here we will set our default gateway" was already made above. Ping test fails.]
- 7.8) Do "Now, we will configure ours permission lists and bridge protocols",
- TooterTurtle(config)#ip nat inside source list 101 interface FastEthernet4 overload
- TooterTurtle(config)#ip nat inside source list 102 interface FastEthernet4 overload
- TooterTurtle(config)#access-list 100 permit udp any any eq bootpc
- TooterTurtle(config)#access-list 101 permit ip 192.168.10.0 0.0.0.255 any
- TooterTurtle(config)#access-list 102 permit 10 10.0.0.0 0.0.0.255 any
- TooterTurtle(config)#ip access-list extended vlan1
- TooterTurtle(config-etc-nacl)#deny ip 10.0.0.0 0.0.0.255 any
- TooterTurtle(config-etc-nacl)#permit ip any any
- TooterTurtle(config-etc-nacl)#exit
- TooterTurtle(config)#bridge 1 protocol ieee
- TooterTurtle(config)#bridge 1 route ip
- 7.9) Do "Next step is configure ours dhcp and excluded dhcp"
- TooterTurtle(config)#ip dns server
- TooterTurtle(config)#ip dhcp pool vlan1
- TooterTurtle(dhcp-config)#import all
- TooterTurtle(dhcp-config)#network 192.168.10.0 255.255.255.0
- TooterTurtle(dhcp-config)#dns-server 192.168.10.1
- TooterTurtle(dhcp-config)#default-router 192.168.10.1
- TooterTurtle(dhcp-config)#domain-name INTERNAL
- TooterTurtle(dhcp-config)#exit
- TooterTurtle(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.10
- TooterTurtle(config)#ip dhcp excluded-address 10.0.0.1 10.0.0.10
- [UPDATE: This config was sufficient to access the internet, but DNS will not work. Add the global config command, "ip domain-lookup" [11]. It seems missing from the How-To.]
- 7.10) Do "Finalizing the main configuration, we will configure our WAN port"
- TooterTurtle(config)#int FastEthernet4
- TooterTurtle(config-if)#ip address dhcp
- TooterTurtle(config-if)#ip verify unicast source reachable-via rx allow-default 100
- TooterTurtle(config-if)#no ip redirects
- TooterTurtle(config-if)#no ip unreachables
- TooterTurtle(config-if)#no ip proxy-arp
- TooterTurtle(config-if)#ip nat outside
- TooterTurtle(config-if)#ip virtual-reassembly
- TooterTurtle(config-if)#speed auto
- TooterTurtle(config-if)#full-duplex
- TooterTurtle(config-if)#exit
- 7.11) Do "After doing all configurations, turn the interfaces..."
- TooterTurtle(config)#int FastEthernet0
- TooterTurtle(config-if)#no shutdown
- TooterTurtle(config-if)#switchport access vlan 1
- TooterTurtle(config-if)#exit
- TooterTurtle(config)#int FastEthernet4
- TooterTurtle(config-if)#no shutdown
- TooterTurtle(config-if)#exit
- TooterTurtle(config)#int vlan 1
- TooterTurtle(config-if)#no shutdown
- TooterTurtle(config-if)#exit
- [That's it! The 871 is now pingable!]
- 8) One final Gotcha.
- From the CCP Users Guide, p135. Starting with "Create a New Interface"
- Step 1 Click Configure > Interface Management > Interface and Connections.
- I get an application error: Security Exception
- Missing required Permissions manifest attribute in main jar:
- http://127.0.0.1:8600/Counterpoint/ssdm-cp-1.1.jar
- 8.1) A quick search of the internet finds an easy fix [10]
- In Control Panel >> Java >>
- Set security to medium
- --- LINKS
- [1]: http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/fundamentals/command/cf_command_ref/F_through_K.html#wp2689140485]
- [2]: http://windowsitpro.com/networking/9-steps-setting-cisco-router
- [3]: http://www.cisco.com/c/en/us/td/docs/net_mgmt/cisco_configuration_professional/v2_7/rlsnts/ccp_v27_rel_notes.html#wp46103
- [4]: http://ciscorouterswitch.over-blog.com/article-cisco-871-interfaces-and-basic-configuration-80487118.html
- [5]: http://www.xiitec.com/blog/2013/04/29/cisco-871w-configuration-for-small-offices/
- [6]: Cisco Networking All-In-One For Dummies (2011). P356
- [7]: http://www.techexams.net/forums/ccna-ccent/11287-configuring-vlans-use-vlan-database.html
- [8]: http://certificationchat.com/forum/cisco-associate-forums/ccna/1867-default-v-lan-1
- https://learningnetwork.cisco.com/thread/58474
- [9]: http://www.cisco.com/c/en/us/support/docs/ios-nx-os-software/ios-software-releases-123-mainline/46509-factory-default.html
- [10]: https://community.oracle.com/thread/2620082
- [11]: https://supportforums.cisco.com/thread/139095
Advertisement
Add Comment
Please, Sign In to add comment
Advertisement