SHOW:
|
|
- or go back to the newest paste.
1 | *** ip hotspot user profile ---> on login *** | |
2 | ||
3 | 1. user profile "1jam-expired-1hari" , on login script : | |
4 | *** copas script dibawah ini di on login user profile **** | |
5 | { | |
6 | :local usernya $user; | |
7 | :if ([/ip hotspot user find name=$usernya limit-uptime=1h]="") do={/ip hotspot user set [find name=$usernya] limit-uptime=1h | |
8 | /ip hotspot active remove [find user=$usernya] | |
9 | } | |
10 | :if ([/system schedule find name=$usernya]="") do={ | |
11 | /system schedule add name=$usernya interval=1d on-event="/ip hotspot user remove [find name=$usernya]\r\n/ip hotspot active remove [find user=$usernya]\r\n/system schedule remove [find name=$usernya]\r\n/ip hotspot cookie remove [find user=$usernya]" | |
12 | } | |
13 | } | |
14 | *** yang ini jangan ikut di copas *** | |
15 | ||
16 | 2. tinggal ubah bagian limit-uptime=1h menjadi 2h atau 3h dan seterusnya, dimaan h=jam, dan ubah expired harinya di bagian interval=1d menjadi 2d atau 3d dan seterusnya dimana d=hari | |
17 | ||
18 | ||
19 | ||
20 | 3. user profile "1GB-expired-1hari" , on login script : | |
21 | *** copas script dibawah ini di on login user profile **** | |
22 | { | |
23 | :local usernya $user; | |
24 | :if ([/ip hotspot user find name=$usernya limit-bytes-total=1073741824]="") do={/ip hotspot user set [find name=$usernya] limit-bytes-total=1073741824 | |
25 | /ip hotspot active remove [find user=$usernya] | |
26 | } | |
27 | :if ([/system schedule find name=$usernya]="") do={ | |
28 | /system schedule add name=$usernya interval=1d on-event="/ip hotspot user remove [find name=$usernya]\r\n/ip hotspot active remove [find user=$usernya]\r\n/system schedule remove [find name=$usernya]\r\n/system schedule remove [find name=$usernya]\r\n/ip hotspot cookie remove [find user=$usernya]" | |
29 | } | |
30 | } | |
31 | *** yang ini jangan ikut di copas *** | |
32 | ||
33 | 4. tinggal ubah bagian limit-bytes-total=1073741824 menjadi misal 2GB hasil perkalian 2 x 1073741824 dan seterusnya, dan ubah expired harinya di bagian interval=1d menjadi 2d atau 3d dan seterusnya dimana d=hari |