Advertisement
Not a member of Pastebin yet?
Sign Up,
it unlocks many cool features!
- for port 80
- eth1=LAN Interface
- 192.168.2.1 = IP of Squid Proxy Server LAN interface (eth1)
- 192.168.100.0/24 = Network for LAN users
- 192.168.2.254 = IP Mikrotik Proxy Interface IP (Squid)
- /interface ethernet
- set 0 name=LAN
- set 1 name=SQUID
- set 2 name=WAN
- /ip address
- add address=192.168.1.1/24 interface=WAN network=192.168.0.0
- add address=192.168.2.254/24 interface=SQUID network=192.168.50.0
- add address=192.168.100.254/24 interface=LAN network=192.168.100.0
- /ip firewall mangle
- add action=mark-routing chain=prerouting dst-port=80 new-routing-mark=http protocol=tcp
- /ip firewall nat
- add chain=srcnat dst-port=80 protocol=tcp
- /ip route
- add distance=1 gateway=192.168.2.1 routing-mark=http
- + port 443 "https"
- /ip firewall mangle
- add action=mark-routing chain=prerouting dst-port=443 new-routing-mark=https protocol=tcp
- /ip firewall nat
- add chain=srcnat dst-port=443 protocol=tcp
- /ip route
- add distance=1 gateway=192.168.2.1 routing-mark=https
Advertisement
Add Comment
Please, Sign In to add comment
Advertisement