Advertisement
Not a member of Pastebin yet?
Sign Up,
it unlocks many cool features!
- //SOURCE: http://msdn.microsoft.com/en-us/library/13940fs2.aspx
- //HOW TO RETURN TO A CERTAIN SPOT IN CODE, C# 2lines of code :p
- //func: & goto func;
- class SwitchTest
- {
- static void Main()
- {
- Console.WriteLine("Coffee sizes: 1=Small 2=Medium 3=Large");
- Console.Write("Please enter your selection: ");
- string s = Console.ReadLine();
- int n = int.Parse(s);
- int cost = 0;
- switch (n)
- {
- case 1:
- cost += 25;
- break;
- case 2:
- cost += 25;
- goto case 1;
- case 3:
- cost += 50;
- goto case 1;
- default:
- Console.WriteLine("Invalid selection.");
- break;
- }
- if (cost != 0)
- {
- Console.WriteLine("Please insert {0} cents.", cost);
- }
- Console.WriteLine("Thank you for your business.");
- // Keep the console open in debug mode.
- Console.WriteLine("Press any key to exit.");
- Console.ReadKey();
- }
- }
- /*
- Sample Input: 2
- Sample Output:
- Coffee sizes: 1=Small 2=Medium 3=Large
- Please enter your selection: 2
- Please insert 50 cents.
- Thank you for your business.
- */
- //The following example demonstrates using goto to break out from nested loops.
- ///C#
- public class GotoTest1
- {
- static void Main()
- {
- int x = 200, y = 4;
- int count = 0;
- string[,] array = new string[x, y];
- // Initialize the array:
- for (int i = 0; i < x; i++)
- for (int j = 0; j < y; j++)
- array[i, j] = (++count).ToString();
- // Read input:
- Console.Write("Enter the number to search for: ");
- // Input a string:
- string myNumber = Console.ReadLine();
- // Search:
- for (int i = 0; i < x; i++)
- {
- for (int j = 0; j < y; j++)
- {
- if (array[i, j].Equals(myNumber))
- {
- goto Found;
- }
- }
- }
- Console.WriteLine("The number {0} was not found.", myNumber);
- goto Finish;
- Found:
- Console.WriteLine("The number {0} is found.", myNumber);
- Finish:
- Console.WriteLine("End of search.");
- // Keep the console open in debug mode.
- Console.WriteLine("Press any key to exit.");
- Console.ReadKey();
- }
- }
- /*
- Sample Input: 44
- Sample Output
- Enter the number to search for: 44
- The number 44 is found.
- End of search.
- */
Advertisement
Add Comment
Please, Sign In to add comment
Advertisement