Not a member of Pastebin yet?
Sign Up,
it unlocks many cool features!
- # feb/26/2022 07:35:23 by RouterOS 6.48.6
- /interface ethernet
- set [ find default-name=ether1 ] name=ether1_ISP
- set [ find default-name=ether2 ] name=ether2_Laptop
- set [ find default-name=ether3 ] name=ether3_Hotspot_Rumah
- set [ find default-name=ether4 ] name=ether4_Hotspot_Publik
- /interface wireless security-profiles
- set [ find default=yes ] supplicant-identity=MikroTik
- /ip firewall layer7-protocol
- add name=facebook regexp="^.+(facebook.com).*\$"
- add name=youtube regexp="^.+(youtube.com|www.youtube.com|m.youtube.com|ytimg.c\
- om|s.ytimg.com|ytimg.l.google.com|youtube.l.google.com|i.google.com|google\
- video.com|youtu.be).*\$"
- /ip hotspot profile
- set [ find default=yes ] dns-name=sebuahhobi.net hotspot-address=10.20.3.1 \
- html-directory=disk1/Ramadhan1442H login-by=http-chap,http-pap,mac-cookie
- add dns-name=sebuahhobi.net hotspot-address=10.20.3.1 html-directory=\
- disk1/Ramadhan1442H login-by=http-chap,http-pap,mac-cookie name=hsprof1
- add dns-name=sebuahhobi.net hotspot-address=10.15.20.1 html-directory=\
- disk1/Ramadhan1442H login-by=http-chap,http-pap,mac-cookie name=hsprof2
- /ip hotspot user profile
- add name=1gb_2d_5000_1M_1M on-login=":put (\",rem,5000,2d,5000,,Disable,\"); {\
- :local date [ /system clock get date ];:local year [ :pick \$date 7 11 ];:\
- local month [ :pick \$date 0 3 ];:local comment [ /ip hotspot user get [/i\
- p hotspot user find where name=\"\$user\"] comment]; :local ucode [:pic \$\
- comment 0 2]; :if (\$ucode = \"vc\" or \$ucode = \"up\" or \$comment = \"\
- \") do={ /sys sch add name=\"\$user\" disable=no start-date=\$date interva\
- l=\"2d\"; :delay 2s; :local exp [ /sys sch get [ /sys sch find where name=\
- \"\$user\" ] next-run]; :local getxp [len \$exp]; :if (\$getxp = 15) do={ \
- :local d [:pic \$exp 0 6]; :local t [:pic \$exp 7 16]; :local s (\"/\"); :\
- local exp (\"\$d\$s\$year \$t\"); /ip hotspot user set comment=\$exp [find\
- \_where name=\"\$user\"];}; :if (\$getxp = 8) do={ /ip hotspot user set co\
- mment=\"\$date \$exp\" [find where name=\"\$user\"];}; :if (\$getxp > 15) \
- do={ /ip hotspot user set comment=\$exp [find where name=\"\$user\"];}; /s\
- ys sch remove [find where name=\"\$user\"]}}" parent-queue=none \
- rate-limit=1M/1M
- add name=2gb_7d_10000_512k_1M on-login=":put (\",rem,10000,7d,10000,,Disable,\
- \"); {:local date [ /system clock get date ];:local year [ :pick \$date 7 \
- 11 ];:local month [ :pick \$date 0 3 ];:local comment [ /ip hotspot user g\
- et [/ip hotspot user find where name=\"\$user\"] comment]; :local ucode [:\
- pic \$comment 0 2]; :if (\$ucode = \"vc\" or \$ucode = \"up\" or \$comment\
- \_= \"\") do={ /sys sch add name=\"\$user\" disable=no start-date=\$date i\
- nterval=\"7d\"; :delay 2s; :local exp [ /sys sch get [ /sys sch find where\
- \_name=\"\$user\" ] next-run]; :local getxp [len \$exp]; :if (\$getxp = 15\
- ) do={ :local d [:pic \$exp 0 6]; :local t [:pic \$exp 7 16]; :local s (\"\
- /\"); :local exp (\"\$d\$s\$year \$t\"); /ip hotspot user set comment=\$ex\
- p [find where name=\"\$user\"];}; :if (\$getxp = 8) do={ /ip hotspot user \
- set comment=\"\$date \$exp\" [find where name=\"\$user\"];}; :if (\$getxp \
- > 15) do={ /ip hotspot user set comment=\$exp [find where name=\"\$user\"]\
- ;}; /sys sch remove [find where name=\"\$user\"]}}" parent-queue=none \
- rate-limit=512k/1M
- add name=10gb_30d_50000_1M_1536k on-login=":put (\",rem,50000,30d,50000,,Disab\
- le,\"); {:local date [ /system clock get date ];:local year [ :pick \$date\
- \_7 11 ];:local month [ :pick \$date 0 3 ];:local comment [ /ip hotspot us\
- er get [/ip hotspot user find where name=\"\$user\"] comment]; :local ucod\
- e [:pic \$comment 0 2]; :if (\$ucode = \"vc\" or \$ucode = \"up\" or \$com\
- ment = \"\") do={ /sys sch add name=\"\$user\" disable=no start-date=\$dat\
- e interval=\"30d\"; :delay 2s; :local exp [ /sys sch get [ /sys sch find w\
- here name=\"\$user\" ] next-run]; :local getxp [len \$exp]; :if (\$getxp =\
- \_15) do={ :local d [:pic \$exp 0 6]; :local t [:pic \$exp 7 16]; :local s\
- \_(\"/\"); :local exp (\"\$d\$s\$year \$t\"); /ip hotspot user set comment\
- =\$exp [find where name=\"\$user\"];}; :if (\$getxp = 8) do={ /ip hotspot \
- user set comment=\"\$date \$exp\" [find where name=\"\$user\"];}; :if (\$g\
- etxp > 15) do={ /ip hotspot user set comment=\$exp [find where name=\"\$us\
- er\"];}; /sys sch remove [find where name=\"\$user\"]}}" parent-queue=\
- none rate-limit=1M/1536k
- add name=15gb_30d_75000_1M_1536k on-login=":put (\",rem,75000,30d,75000,,Disab\
- le,\"); {:local date [ /system clock get date ];:local year [ :pick \$date\
- \_7 11 ];:local month [ :pick \$date 0 3 ];:local comment [ /ip hotspot us\
- er get [/ip hotspot user find where name=\"\$user\"] comment]; :local ucod\
- e [:pic \$comment 0 2]; :if (\$ucode = \"vc\" or \$ucode = \"up\" or \$com\
- ment = \"\") do={ /sys sch add name=\"\$user\" disable=no start-date=\$dat\
- e interval=\"30d\"; :delay 2s; :local exp [ /sys sch get [ /sys sch find w\
- here name=\"\$user\" ] next-run]; :local getxp [len \$exp]; :if (\$getxp =\
- \_15) do={ :local d [:pic \$exp 0 6]; :local t [:pic \$exp 7 16]; :local s\
- \_(\"/\"); :local exp (\"\$d\$s\$year \$t\"); /ip hotspot user set comment\
- =\$exp [find where name=\"\$user\"];}; :if (\$getxp = 8) do={ /ip hotspot \
- user set comment=\"\$date \$exp\" [find where name=\"\$user\"];}; :if (\$g\
- etxp > 15) do={ /ip hotspot user set comment=\$exp [find where name=\"\$us\
- er\"];}; /sys sch remove [find where name=\"\$user\"]}}" parent-queue=\
- none rate-limit=2M/2M
- add name=unlimited_30d_150000_1M_1536k on-login=":put (\",rem,150000,31d,15000\
- 0,,Enable,\"); {:local date [ /system clock get date ];:local year [ :pick\
- \_\$date 7 11 ];:local month [ :pick \$date 0 3 ];:local comment [ /ip hot\
- spot user get [/ip hotspot user find where name=\"\$user\"] comment]; :loc\
- al ucode [:pic \$comment 0 2]; :if (\$ucode = \"vc\" or \$ucode = \"up\" o\
- r \$comment = \"\") do={ /sys sch add name=\"\$user\" disable=no start-dat\
- e=\$date interval=\"31d\"; :delay 2s; :local exp [ /sys sch get [ /sys sch\
- \_find where name=\"\$user\" ] next-run]; :local getxp [len \$exp]; :if (\
- \$getxp = 15) do={ :local d [:pic \$exp 0 6]; :local t [:pic \$exp 7 16]; \
- :local s (\"/\"); :local exp (\"\$d\$s\$year \$t\"); /ip hotspot user set \
- comment=\$exp [find where name=\"\$user\"];}; :if (\$getxp = 8) do={ /ip h\
- otspot user set comment=\"\$date \$exp\" [find where name=\"\$user\"];}; :\
- if (\$getxp > 15) do={ /ip hotspot user set comment=\$exp [find where name\
- =\"\$user\"];}; /sys sch remove [find where name=\"\$user\"]; [:local mac \
- \$\"mac-address\"; /ip hotspot user set mac-address=\$mac [find where name\
- =\$user]]}}" parent-queue=none rate-limit=1M/2M
- add name=1_tahun_wa_rumah_1M_1M_50Gb on-login=":put (\",rem,0,360d,0,,Enable,\
- \"); {:local date [ /system clock get date ];:local year [ :pick \$date 7 \
- 11 ];:local month [ :pick \$date 0 3 ];:local comment [ /ip hotspot user g\
- et [/ip hotspot user find where name=\"\$user\"] comment]; :local ucode [:\
- pic \$comment 0 2]; :if (\$ucode = \"vc\" or \$ucode = \"up\" or \$comment\
- \_= \"\") do={ /sys sch add name=\"\$user\" disable=no start-date=\$date i\
- nterval=\"360d\"; :delay 2s; :local exp [ /sys sch get [ /sys sch find whe\
- re name=\"\$user\" ] next-run]; :local getxp [len \$exp]; :if (\$getxp = 1\
- 5) do={ :local d [:pic \$exp 0 6]; :local t [:pic \$exp 7 16]; :local s (\
- \"/\"); :local exp (\"\$d\$s\$year \$t\"); /ip hotspot user set comment=\$\
- exp [find where name=\"\$user\"];}; :if (\$getxp = 8) do={ /ip hotspot use\
- r set comment=\"\$date \$exp\" [find where name=\"\$user\"];}; :if (\$getx\
- p > 15) do={ /ip hotspot user set comment=\$exp [find where name=\"\$user\
- \"];}; /sys sch remove [find where name=\"\$user\"]; [:local mac \$\"mac-a\
- ddress\"; /ip hotspot user set mac-address=\$mac [find where name=\$user]]\
- }}" parent-queue=none rate-limit=3M/3M
- /ip pool
- add name=dhcp_pool0 ranges=192.168.22.3-192.168.22.10
- add name=hs-pool-3-rumah ranges=10.20.3.11-10.20.3.254
- add name=hs-pool-4-publik ranges=10.15.20.11-10.15.20.254
- /ip dhcp-server
- add address-pool=dhcp_pool0 disabled=no interface=ether2_Laptop lease-time=\
- 1d10m name=dhcp1
- add address-pool=hs-pool-3-rumah disabled=no interface=ether3_Hotspot_Rumah \
- lease-time=1h name=ether3_rumah
- add address-pool=hs-pool-4-publik disabled=no interface=ether4_Hotspot_Publik \
- lease-time=1h name=ether4_publik
- /ip hotspot
- add address-pool=hs-pool-3-rumah addresses-per-mac=1 disabled=no interface=\
- ether3_Hotspot_Rumah name=hotspot1_rumah profile=hsprof1
- add address-pool=hs-pool-3-rumah addresses-per-mac=1 disabled=no interface=\
- ether4_Hotspot_Publik name=Hostpot2_Publik profile=hsprof2
- /ip address
- add address=192.168.22.2/10 interface=ether2_Laptop network=192.128.0.0
- add address=10.20.3.1/24 interface=ether3_Hotspot_Rumah network=10.20.3.0
- add address=10.15.20.1/24 interface=ether4_Hotspot_Publik network=10.15.20.0
- /ip dhcp-client
- add disabled=no interface=ether1_ISP
- /ip dhcp-server network
- add address=10.15.20.0/24 comment="hotspot network" gateway=10.15.20.1
- add address=10.20.3.0/24 comment="hotspot network" gateway=10.20.3.1
- add address=192.128.0.0/10 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.22.2
- /ip dns
- set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4,1.1.1.1,1.0.0.1
- /ip firewall address-list
- add address=10.20.3.0/24 list=IP-Hotspot-Rumah
- add address=10.15.20.0/24 list=IP-Hotspot-Publik
- /ip firewall filter
- add action=passthrough chain=unused-hs-chain comment=\
- "place hotspot rules here" disabled=yes
- add action=drop chain=forward comment=Blok-TIkTok dst-address-list=\
- TikTok-List
- add action=drop chain=output dst-address-list=TikTok-List
- add action=drop chain=forward comment=Blok-YouTube dst-address-list=\
- YouTube-List
- add action=drop chain=output dst-address-list=YouTube-List
- add action=drop chain=forward comment=Blok-Layer-7 dst-port=80,443 \
- in-interface=ether3_Hotspot_Rumah layer7-protocol=facebook protocol=tcp
- add action=drop chain=forward comment="Game-Blokir ML TCP" dst-port=\
- 5000-5221,5224-5227,5229-5241,5243-5508,5551-5559,5601-5700,9001,9443 \
- protocol=tcp src-address=10.20.3.0
- add action=drop chain=forward dst-port=5520-5529,10003,30000-30300 protocol=\
- tcp src-address=10.20.3.0
- add action=drop chain=forward dst-port=\
- 4001-4009,5000-5221,5224-5241,5243-5508,5551-5559,5601-5700 protocol=udp \
- src-address=10.20.3.0
- add action=drop chain=forward dst-port=\
- 2702,3702,5517,5520-5529,8001,9000-9010,9992,10003,30000-30300 protocol=\
- udp src-address=10.20.3.0
- add action=drop chain=forward comment="Game-Blokir Free Fire" dst-port="6006,6\
- 674,7006,7889,8001-8012,9006,10000-10012,11000-11019,12006,12008,13006" \
- protocol=tcp src-address=10.20.3.0
- add action=drop chain=forward dst-port=20561,39003,39006,39698,39779,39800 \
- protocol=tcp src-address=10.20.3.0
- add action=drop chain=forward dst-port=\
- 6006,6008,7008,8008,9008,10000-10013,10100,11000-11019,12008,13008 \
- protocol=udp src-address=10.20.3.0
- add action=drop chain=forward comment="Game-Blokir PUBG" dst-port=\
- 8011,9030,10491,10612,12235,13004,13748,17000,17500,20000-20002 protocol=\
- udp src-address=10.20.3.0
- add action=drop chain=forward dst-port=\
- 7086-7995,10039,10096,11455,12070-12460,13894,13972,41182-41192 protocol=\
- udp src-address=10.20.3.0
- add action=drop chain=forward dst-port=\
- 7889,10012,13004,14000,17000,17500,18081,20000-20002,20371 protocol=tcp \
- src-address=10.20.3.0
- add action=drop chain=forward comment="Game-Blokir Genshin Impact" dst-port=\
- 42472 protocol=tcp src-address=10.20.3.0
- add action=drop chain=forward dst-port=42472,22101-22102 protocol=udp \
- src-address=10.20.3.0
- add action=drop chain=forward comment="Game-Blokir Call of Duty" dst-port=\
- 3013,10000-10019,18082,50000,65010,65050 protocol=tcp src-address=\
- 10.20.3.0
- add action=drop chain=forward dst-port=\
- 7085-7995,8700,9030,10010-10019,17000-20100 protocol=udp src-address=\
- 10.20.3.0
- add action=drop chain=forward comment="Game-Blokir AOV" dst-port=10001-10094 \
- protocol=tcp src-address=10.20.3.0
- add action=drop chain=forward comment=COC dst-port=9330-9340 protocol=udp \
- src-address=10.20.3.0
- add action=drop chain=forward comment=COC dst-port=9330-9340 protocol=tcp \
- src-address=10.20.3.0
- add action=drop chain=forward dst-port=16300-16350 protocol=udp src-address=\
- 10.20.3.0
- add action=drop chain=forward comment=LOL dst-port=2080-2099 protocol=tcp \
- src-address=10.20.3.0
- add action=drop chain=forward comment=LOL dst-port=5100 protocol=udp \
- src-address=10.20.3.0
- add action=drop chain=forward comment=DOTA2 dst-port=\
- 9100-9200,8230-8250,8110-8120,27000-28998 protocol=tcp src-address=\
- 10.20.3.0
- add action=drop chain=forward dst-port=27000-28998,39000 protocol=udp \
- src-address=10.20.3.0
- add action=drop chain=forward comment="FIFA ONLINE" dst-port=7770-7790 \
- protocol=tcp src-address=10.20.3.0
- add action=drop chain=forward dst-port=10101-10201,10080-10110,17000-18000 \
- protocol=udp src-address=10.20.3.0
- add action=drop chain=forward comment=Blok-Facebook dst-address-list=\
- Facebook-List
- add action=drop chain=output dst-address-list=Facebook-List
- add action=drop chain=output comment="Blokir IG" dst-address-list=IG-List
- add action=drop chain=forward dst-address-list=IG-List
- add action=drop chain=forward comment="Blokir Twitter" dst-address-list=\
- Twitter-List
- add action=drop chain=output dst-address-list=Twitter-List
- add action=drop chain=output comment="Blokir SnackVideo" dst-address-list=\
- SnackVideo-List
- add action=drop chain=forward dst-address-list=SnackVideo-List
- /ip firewall nat
- add action=passthrough chain=unused-hs-chain comment=\
- "place hotspot rules here" disabled=yes
- add action=masquerade chain=srcnat out-interface=ether1_ISP
- add action=masquerade chain=srcnat comment="masquerade hotspot network" \
- src-address=10.20.3.0/24
- /ip firewall raw
- add action=add-dst-to-address-list address-list=TikTok-List \
- address-list-timeout=none-dynamic chain=prerouting comment=TIKTOK \
- content=.tiktok.com dst-address-list=!IP-Hotspot-Rumah src-address-list=\
- IP-Hotspot-Rumah
- add action=add-dst-to-address-list address-list=TikTok-List \
- address-list-timeout=none-dynamic chain=prerouting content=.tiktokv.com \
- dst-address-list=!IP-Hotspot-Rumah src-address-list=IP-Hotspot-Rumah
- add action=add-dst-to-address-list address-list=TikTok-List \
- address-list-timeout=none-dynamic chain=prerouting content=.tiktokcdn.com \
- dst-address-list=!IP-Hotspot-Rumah src-address-list=IP-Hotspot-Rumah
- add action=add-dst-to-address-list address-list=TikTok-List \
- address-list-timeout=none-dynamic chain=prerouting content=\
- .byteoversea.com dst-address-list=!IP-Hotspot-Rumah src-address-list=\
- IP-Hotspot-Rumah
- add action=add-dst-to-address-list address-list=TikTok-List \
- address-list-timeout=none-dynamic chain=prerouting content=.ibyteimg.com \
- dst-address-list=!IP-Hotspot-Rumah src-address-list=IP-Hotspot-Rumah
- add action=add-dst-to-address-list address-list=TikTok-List \
- address-list-timeout=none-dynamic chain=prerouting content=.ibytedtos.com \
- dst-address-list=!IP-Hotspot-Rumah src-address-list=IP-Hotspot-Rumah
- add action=add-dst-to-address-list address-list=TikTok-List \
- address-list-timeout=none-dynamic chain=prerouting content=.myqcloud.com \
- dst-address-list=!IP-Hotspot-Rumah src-address-list=IP-Hotspot-Rumah
- add action=add-dst-to-address-list address-list=TikTok-List \
- address-list-timeout=none-dynamic chain=prerouting content=.myqcloud.com \
- dst-address-list=!IP-Hotspot-Rumah src-address-list=IP-Hotspot-Rumah
- add action=add-dst-to-address-list address-list=YouTube-List \
- address-list-timeout=none-dynamic chain=prerouting comment=YOUTUBE \
- content=.youtube.com dst-address-list=!IP-Hotspot-Rumah src-address-list=\
- IP-Hotspot-Rumah
- add action=add-dst-to-address-list address-list=YouTube-List \
- address-list-timeout=none-dynamic chain=prerouting content=\
- .googlevideo.com dst-address-list=!IP-Hotspot-Rumah src-address-list=\
- IP-Hotspot-Rumah
- add action=add-dst-to-address-list address-list=YouTube-List \
- address-list-timeout=none-dynamic chain=prerouting content=.ytimg.com \
- dst-address-list=!IP-Hotspot-Rumah src-address-list=IP-Hotspot-Rumah
- add action=add-dst-to-address-list address-list=Facebook-List \
- address-list-timeout=none-dynamic chain=prerouting comment=FACEBOOK \
- content=.facebook.com dst-address-list=!IP-Hotspot-umum src-address-list=\
- IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=Facebook-List \
- address-list-timeout=none-dynamic chain=prerouting content=.facebook.net \
- dst-address-list=!IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=Facebook-List \
- address-list-timeout=none-dynamic chain=prerouting content=.fbcdn.net \
- dst-address-list=!IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=Facebook-List \
- address-list-timeout=none-dynamic chain=prerouting content=fb.com \
- dst-address-list=!IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=Facebook-List \
- address-list-timeout=none-dynamic chain=prerouting content=.fbsbx.com \
- dst-address-list=!IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=Facebook-List \
- address-list-timeout=none-dynamic chain=prerouting content=fb.gg \
- dst-address-list=!IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=Facebook-List \
- address-list-timeout=none-dynamic chain=prerouting content=fbwat.ch \
- dst-address-list=!IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=Facebook-List \
- address-list-timeout=none-dynamic chain=prerouting content=messenger.com \
- dst-address-list=!IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=Facebook-List \
- address-list-timeout=none-dynamic chain=prerouting content=m.me \
- dst-address-list=!IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=IG-List address-list-timeout=\
- none-dynamic chain=prerouting comment=IG content=.instagram.com \
- dst-address-list=!IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=IG-List address-list-timeout=\
- none-dynamic chain=prerouting content=.cdninstagram.com dst-address-list=\
- !IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=Twitter-List \
- address-list-timeout=none-dynamic chain=prerouting comment=Twitter \
- content=twitter.com dst-address-list=!IP-Hotspot-umum src-address-list=\
- IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=Twitter-List \
- address-list-timeout=none-dynamic chain=prerouting content=.twitter.com \
- dst-address-list=!IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=Twitter-List \
- address-list-timeout=none-dynamic chain=prerouting content=.twimg.com \
- dst-address-list=!IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=Twitter-List \
- address-list-timeout=none-dynamic chain=prerouting content=t.co \
- dst-address-list=!IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=SnackVideo-List \
- address-list-timeout=none-dynamic chain=prerouting comment=SnackVideo \
- content=.snackvideo.com dst-address-list=!IP-Hotspot-umum \
- src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=SnackVideo-List \
- address-list-timeout=none-dynamic chain=prerouting content=.myqcloud.com \
- dst-address-list=!IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- add action=add-dst-to-address-list address-list=SnackVideo-List \
- address-list-timeout=none-dynamic chain=prerouting content=.snackvideo.in \
- dst-address-list=!IP-Hotspot-umum src-address-list=IP-Hotspot-umum
- /ip hotspot user
- add comment="feb/28/2022 06:58:11" limit-bytes-total=1073741824 limit-uptime=\
- 2d name=tkvg6925 password=tkvg6925 profile=1gb_2d_5000_1M_1M
- /ip proxy
- set enabled=yes
- /system clock
- set time-zone-name=Asia/Jakarta
- /system identity
- set name=Sebuahhobi
- /system logging
- add action=disk prefix=-> topics=hotspot,info,debug
- /system ntp client
- set enabled=yes server-dns-names=id.pool.ntp.org
- /system scheduler
- add comment="Monitor Profile 1gb_2d_5000_1M_1M" interval=2m33s name=\
- 1gb_2d_5000_1M_1M on-event=":local dateint do={:local montharray ( \"jan\"\
- ,\"feb\",\"mar\",\"apr\",\"may\",\"jun\",\"jul\",\"aug\",\"sep\",\"oct\",\
- \"nov\",\"dec\" );:local days [ :pick \$d 4 6 ];:local month [ :pick \$d 0\
- \_3 ];:local year [ :pick \$d 7 11 ];:local monthint ([ :find \$montharray\
- \_\$month]);:local month (\$monthint + 1);:if ( [len \$month] = 1) do={:lo\
- cal zero (\"0\");:return [:tonum (\"\$year\$zero\$month\$days\")];} else={\
- :return [:tonum (\"\$year\$month\$days\")];}}; :local timeint do={ :local \
- hours [ :pick \$t 0 2 ]; :local minutes [ :pick \$t 3 5 ]; :return (\$hour\
- s * 60 + \$minutes) ; }; :local date [ /system clock get date ]; :local ti\
- me [ /system clock get time ]; :local today [\$dateint d=\$date] ; :local \
- curtime [\$timeint t=\$time] ; :foreach i in [ /ip hotspot user find where\
- \_profile=\"1gb_2d_5000_1M_1M\" ] do={ :local comment [ /ip hotspot user g\
- et \$i comment]; :local name [ /ip hotspot user get \$i name]; :local gett\
- ime [:pic \$comment 12 20]; :if ([:pic \$comment 3] = \"/\" and [:pic \$co\
- mment 6] = \"/\") do={:local expd [\$dateint d=\$comment] ; :local expt [\
- \$timeint t=\$gettime] ; :if ((\$expd < \$today and \$expt < \$curtime) or\
- \_(\$expd < \$today and \$expt > \$curtime) or (\$expd = \$today and \$exp\
- t < \$curtime)) do={ [ /ip hotspot user remove \$i ]; [ /ip hotspot active\
- \_remove [find where user=\$name] ];}}}" policy=\
- ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
- start-date=dec/27/2021 start-time=05:18:19
- add comment="Monitor Profile 2gb_7d_10000_512k_1M" interval=2m10s name=\
- 2gb_7d_10000_512k_1M on-event=":local dateint do={:local montharray ( \"ja\
- n\",\"feb\",\"mar\",\"apr\",\"may\",\"jun\",\"jul\",\"aug\",\"sep\",\"oct\
- \",\"nov\",\"dec\" );:local days [ :pick \$d 4 6 ];:local month [ :pick \$\
- d 0 3 ];:local year [ :pick \$d 7 11 ];:local monthint ([ :find \$montharr\
- ay \$month]);:local month (\$monthint + 1);:if ( [len \$month] = 1) do={:l\
- ocal zero (\"0\");:return [:tonum (\"\$year\$zero\$month\$days\")];} else=\
- {:return [:tonum (\"\$year\$month\$days\")];}}; :local timeint do={ :local\
- \_hours [ :pick \$t 0 2 ]; :local minutes [ :pick \$t 3 5 ]; :return (\$ho\
- urs * 60 + \$minutes) ; }; :local date [ /system clock get date ]; :local \
- time [ /system clock get time ]; :local today [\$dateint d=\$date] ; :loca\
- l curtime [\$timeint t=\$time] ; :foreach i in [ /ip hotspot user find whe\
- re profile=\"2gb_7d_10000_512k_1M\" ] do={ :local comment [ /ip hotspot us\
- er get \$i comment]; :local name [ /ip hotspot user get \$i name]; :local \
- gettime [:pic \$comment 12 20]; :if ([:pic \$comment 3] = \"/\" and [:pic \
- \$comment 6] = \"/\") do={:local expd [\$dateint d=\$comment] ; :local exp\
- t [\$timeint t=\$gettime] ; :if ((\$expd < \$today and \$expt < \$curtime)\
- \_or (\$expd < \$today and \$expt > \$curtime) or (\$expd = \$today and \$\
- expt < \$curtime)) do={ [ /ip hotspot user remove \$i ]; [ /ip hotspot act\
- ive remove [find where user=\$name] ];}}}" policy=\
- ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
- start-date=dec/27/2021 start-time=05:32:25
- add comment="Monitor Profile 10gb_30d_50000_1M_1536k" interval=2m33s name=\
- 10gb_30d_50000_1M_1536k on-event=":local dateint do={:local montharray ( \
- \"jan\",\"feb\",\"mar\",\"apr\",\"may\",\"jun\",\"jul\",\"aug\",\"sep\",\"\
- oct\",\"nov\",\"dec\" );:local days [ :pick \$d 4 6 ];:local month [ :pick\
- \_\$d 0 3 ];:local year [ :pick \$d 7 11 ];:local monthint ([ :find \$mont\
- harray \$month]);:local month (\$monthint + 1);:if ( [len \$month] = 1) do\
- ={:local zero (\"0\");:return [:tonum (\"\$year\$zero\$month\$days\")];} e\
- lse={:return [:tonum (\"\$year\$month\$days\")];}}; :local timeint do={ :l\
- ocal hours [ :pick \$t 0 2 ]; :local minutes [ :pick \$t 3 5 ]; :return (\
- \$hours * 60 + \$minutes) ; }; :local date [ /system clock get date ]; :lo\
- cal time [ /system clock get time ]; :local today [\$dateint d=\$date] ; :\
- local curtime [\$timeint t=\$time] ; :foreach i in [ /ip hotspot user find\
- \_where profile=\"10gb_30d_50000_1M_1536k\" ] do={ :local comment [ /ip ho\
- tspot user get \$i comment]; :local name [ /ip hotspot user get \$i name];\
- \_:local gettime [:pic \$comment 12 20]; :if ([:pic \$comment 3] = \"/\" a\
- nd [:pic \$comment 6] = \"/\") do={:local expd [\$dateint d=\$comment] ; :\
- local expt [\$timeint t=\$gettime] ; :if ((\$expd < \$today and \$expt < \
- \$curtime) or (\$expd < \$today and \$expt > \$curtime) or (\$expd = \$tod\
- ay and \$expt < \$curtime)) do={ [ /ip hotspot user remove \$i ]; [ /ip ho\
- tspot active remove [find where user=\$name] ];}}}" policy=\
- ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
- start-date=dec/27/2021 start-time=05:57:13
- add comment="Monitor Profile 15gb_30d_75000_1M_1536k" interval=2m24s name=\
- 15gb_30d_75000_1M_1536k on-event=":local dateint do={:local montharray ( \
- \"jan\",\"feb\",\"mar\",\"apr\",\"may\",\"jun\",\"jul\",\"aug\",\"sep\",\"\
- oct\",\"nov\",\"dec\" );:local days [ :pick \$d 4 6 ];:local month [ :pick\
- \_\$d 0 3 ];:local year [ :pick \$d 7 11 ];:local monthint ([ :find \$mont\
- harray \$month]);:local month (\$monthint + 1);:if ( [len \$month] = 1) do\
- ={:local zero (\"0\");:return [:tonum (\"\$year\$zero\$month\$days\")];} e\
- lse={:return [:tonum (\"\$year\$month\$days\")];}}; :local timeint do={ :l\
- ocal hours [ :pick \$t 0 2 ]; :local minutes [ :pick \$t 3 5 ]; :return (\
- \$hours * 60 + \$minutes) ; }; :local date [ /system clock get date ]; :lo\
- cal time [ /system clock get time ]; :local today [\$dateint d=\$date] ; :\
- local curtime [\$timeint t=\$time] ; :foreach i in [ /ip hotspot user find\
- \_where profile=\"15gb_30d_75000_1M_1536k\" ] do={ :local comment [ /ip ho\
- tspot user get \$i comment]; :local name [ /ip hotspot user get \$i name];\
- \_:local gettime [:pic \$comment 12 20]; :if ([:pic \$comment 3] = \"/\" a\
- nd [:pic \$comment 6] = \"/\") do={:local expd [\$dateint d=\$comment] ; :\
- local expt [\$timeint t=\$gettime] ; :if ((\$expd < \$today and \$expt < \
- \$curtime) or (\$expd < \$today and \$expt > \$curtime) or (\$expd = \$tod\
- ay and \$expt < \$curtime)) do={ [ /ip hotspot user remove \$i ]; [ /ip ho\
- tspot active remove [find where user=\$name] ];}}}" policy=\
- ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
- start-date=dec/27/2021 start-time=02:29:28
- add comment="Monitor Profile unlimited_30d_150000_1M_1536k" interval=2m19s \
- name=unlimited_30d_150000_1M_1536k on-event=":local dateint do={:local mon\
- tharray ( \"jan\",\"feb\",\"mar\",\"apr\",\"may\",\"jun\",\"jul\",\"aug\",\
- \"sep\",\"oct\",\"nov\",\"dec\" );:local days [ :pick \$d 4 6 ];:local mon\
- th [ :pick \$d 0 3 ];:local year [ :pick \$d 7 11 ];:local monthint ([ :fi\
- nd \$montharray \$month]);:local month (\$monthint + 1);:if ( [len \$month\
- ] = 1) do={:local zero (\"0\");:return [:tonum (\"\$year\$zero\$month\$day\
- s\")];} else={:return [:tonum (\"\$year\$month\$days\")];}}; :local timein\
- t do={ :local hours [ :pick \$t 0 2 ]; :local minutes [ :pick \$t 3 5 ]; :\
- return (\$hours * 60 + \$minutes) ; }; :local date [ /system clock get dat\
- e ]; :local time [ /system clock get time ]; :local today [\$dateint d=\$d\
- ate] ; :local curtime [\$timeint t=\$time] ; :foreach i in [ /ip hotspot u\
- ser find where profile=\"unlimited_30d_150000_1M_1536k\" ] do={ :local com\
- ment [ /ip hotspot user get \$i comment]; :local name [ /ip hotspot user g\
- et \$i name]; :local gettime [:pic \$comment 12 20]; :if ([:pic \$comment \
- 3] = \"/\" and [:pic \$comment 6] = \"/\") do={:local expd [\$dateint d=\$\
- comment] ; :local expt [\$timeint t=\$gettime] ; :if ((\$expd < \$today an\
- d \$expt < \$curtime) or (\$expd < \$today and \$expt > \$curtime) or (\$e\
- xpd = \$today and \$expt < \$curtime)) do={ [ /ip hotspot user remove \$i \
- ]; [ /ip hotspot active remove [find where user=\$name] ];}}}" policy=\
- ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
- start-date=feb/06/2022 start-time=01:49:26
- add comment="Monitor Profile 1_tahun_wa_rumah_1M_1M_50Gb" interval=2m28s \
- name=1_tahun_wa_rumah_1M_1M_50Gb on-event=":local dateint do={:local month\
- array ( \"jan\",\"feb\",\"mar\",\"apr\",\"may\",\"jun\",\"jul\",\"aug\",\"\
- sep\",\"oct\",\"nov\",\"dec\" );:local days [ :pick \$d 4 6 ];:local month\
- \_[ :pick \$d 0 3 ];:local year [ :pick \$d 7 11 ];:local monthint ([ :fin\
- d \$montharray \$month]);:local month (\$monthint + 1);:if ( [len \$month]\
- \_= 1) do={:local zero (\"0\");:return [:tonum (\"\$year\$zero\$month\$day\
- s\")];} else={:return [:tonum (\"\$year\$month\$days\")];}}; :local timein\
- t do={ :local hours [ :pick \$t 0 2 ]; :local minutes [ :pick \$t 3 5 ]; :\
- return (\$hours * 60 + \$minutes) ; }; :local date [ /system clock get dat\
- e ]; :local time [ /system clock get time ]; :local today [\$dateint d=\$d\
- ate] ; :local curtime [\$timeint t=\$time] ; :foreach i in [ /ip hotspot u\
- ser find where profile=\"1_tahun_wa_rumah_1M_1M_50Gb\" ] do={ :local comme\
- nt [ /ip hotspot user get \$i comment]; :local name [ /ip hotspot user get\
- \_\$i name]; :local gettime [:pic \$comment 12 20]; :if ([:pic \$comment 3\
- ] = \"/\" and [:pic \$comment 6] = \"/\") do={:local expd [\$dateint d=\$c\
- omment] ; :local expt [\$timeint t=\$gettime] ; :if ((\$expd < \$today and\
- \_\$expt < \$curtime) or (\$expd < \$today and \$expt > \$curtime) or (\$e\
- xpd = \$today and \$expt < \$curtime)) do={ [ /ip hotspot user remove \$i \
- ]; [ /ip hotspot active remove [find where user=\$name] ];}}}" policy=\
- ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
- start-date=feb/23/2022 start-time=04:43:54
Add Comment
Please, Sign In to add comment